[20251211] SSL Certificates Expiration
Resolved
Dec 11 at 12:16pm CET
All systems were reported operational once again at 11.16 UTC.
We have now flagged the key oversights in the process that got us here, and are going to be implementing the necessary changes to minimize the risk going forward.
Once again, we’re truly sorry for the disruption this has caused to your operations, and thank you kindly for your patience.
Affected services
Created
Dec 11 at 11:39am CET
On December 11, 2025 at 10.39 UTC, a series of our SSL Certificates expired, resulting in the prompt interruption of most of our core services through the inability to securely connect to them over HTTPS.
This caused customers to experience browser security warnings or failed SSL / HTTPS connections on their systems.
The team was alerted of and able to correct the failing certificates quickly, but propagation through our infrastructure took longer than expected, which dreadfully extended the downtime period and, more importantly, the impact for our customers.
Apologies for the disruption this has caused to your operations, and thank you kindly for your patience.
Affected services